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1   INTRODUCTION 

OT BioLab+ is an acquisition and processing tool developed by OT Bioelettronica. It is a freeware 

software downloadable at www.otbiolab.it in the Download section, and  

tutorials are available at www.otbiolab.it in the Tutorial section. OT BioLab+ allows to acquire, review 

and process bioelectrical signals detected using the OT Bioelettronica devices listed below: 

 

DUEPRO: is a wearable surface EMG device, records from 2 to 14 channels with 2 auxiliary signals 

(e.g. force, angle).  

 

EMG-USB: surface electromyographic amplifier, up to 128 channels. 

 

EMG-SUB2: surface and intramuscular electromyographic amplifier, up to 256 channels. 

 

EMG-USB2+: surface and intramuscular electromyographic amplifier, up to 256 channels. Each input 

can acquire signals with a different acquisition mode. 

 

FORZA: analog signals amplifier, 1 channel. 

 

MEBA: surface and intramuscular electromyographic amplifier, up to 32 channels. 

 

MUOVI (under development): is a miniaturized wireless and modular HD-sEMG acquisition system 
directly interfacing with laptops, smartphones and tablets, up to 64 monopolar channels (2 probes with 
32 channels each). 
 

QUATTRO: is a portable device for surface EMG data logger that can record up to 37 hours 
continuously the activity of four channels. 
 
 
SESSANTAQUATTRO: surface and intramuscular electromyographic amplifier with Wi-Fi 

communication, up to 64 channels. 

 

QUATTROCENTO: surface and intramuscular electromyographic amplifier, up to 400 channels. 

 

Using OT BioLab+ it is also possible to review and process any kind of signals stored  

in txt format. 

OT BioLab+ has been designed for .Net Framework 4.0 and Windows 10 operating both with 32 and 

64 bit. 

http://www.otbioelettronica.it/
http://www.otbiolab.it/
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2 OT BIOLAB+ INSTALLATION 

 

OT BioLab+ installation procedure requires few minutes and allows to install the software and 

preinstall the drivers for EMG-USB, DUEPRO and QUATTRO. Extract and run the OT BioLab+ setup file. 

The start-up window will appear (see Fig. 2.1), the this is the license agreement window, read carefully 

the license condition and click “Next” to continue. 

FIG. 2.1: OT BioLab+ license agreement window. 

 

The next step requires to choose which drivers install (depending on which device you own) (see Fig. 

2.2). Again, click “Next” to proceed. 
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Fig. 2.2: OT BioLab+ Custom installation. 

 

It is possible to create a desktop shortcut (see Fig. 2.3). 

                        Fig. 2.3: Desktop Shortcut. 
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Now the software is ready to be installed (see Fig.2.4). This window gives a installation summary of the 
components and details. 

      Fig. 2.4: OT BioLab+ installation window.
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3 DRIVERS INSTALLATION 

Drivers installation depends on how many drivers you choose to install. 
 
3.1 EMG-USB DRIVERS 

The installation of EMG-USB drivers can be completed just clicking Next on Fig 3.1. After some seconds 

drivers will be installed and you will reach Fig 3.2. 

Fig. 3.1: EMG-USB drivers installation window. 
 
 

 
Fig. 3.2: EMG-USB drivers installed 
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3.2 DUEPRO DRIVERS 

In order to use DuePro, some steps are required. These windows open automatically during installation. 

1. Install FTDI CDM Drivers 

Fig. 3.3: FTDI CDM Drivers installer. 

 

 

2. Click “Next” 
 

 

Fig. 3.4: Driver installation window. 
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3. Accept agreement 
 

Fig. 3.5: Driver installer License Agreement. 

 
 
 

4. FTDI CDM Drivers installed 

 

Fig. 3.6: Driver installation complete. 
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5. Install Texas Instrument drivers. Click “Next” 
 

Fig. 3.7: Texas instrument Driver installation window. 

 
 

6. Accept agreement                   
 

Fig. 3.8: License Agreement window. 
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7. Install, select the folder and click “Install” 
 

Fig. 3.9: Choose Driver destination folder. 

 
 

8. Open installation folder  
 

Fig. 3.10: Driver installation complete. 
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Fig. 3.11: Driver folder. 

 

9.  Run Setup.exe and click “Next” 

Fig. 3.12: Driver installation. 

 

 

10.  Accept agreement 
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11. Install  

Fig. 3.13: License Agreement. 

 

Fig. 3.14: Choose Driver location folder. 

 

 

12. Texas instrument drivers installed 
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Fig. 3.15: Texas instrument drivers installed. 

 

13. Install Virtual COM port drivers 

 

Fig. 3.16: Virtual COM port installation window. 
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14. Install 

Fig. 3.17: Virtual COM port driver settings. 

 

15.  Open the folder C:\Program Files (x86) 

16.  Go to C:\Program Files (x86)\STMicroelectronics\Software\Virtual comport driver 

 

Fig. 3.18: Virtual COM port drivers location folder. 

 

17.  Choose the right folder. If you have Windows 10, then choose Win8 folder. 

18.  Choose the file depending on your operative system. If your operative system is 64 bits, 

choose dpinst_amd64.exe, otherwise choose dpinst_x86.exe 
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Fig. 3.19: Choose the right file depending on your system. 
 
 

19.  Run it 

 

Fig. 3.20: Virtual COM port drivers installation window. 
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20.  Driver installed 

Fig. 3.21: Virtual COM port drivers installation complete. 
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4 MAIN INTERFACE 
 
Running OT BioLab+ you will meet the main interface, shown in Figure 4.1. 

 

 

Fig. 4.1: OT BioLab+ interface. 

  
The drop-down list of the file toolbar allows you to open, import, save files or close the project. 

Fig. 4.2: OT BioLab+ File toolbar details. 
 

Subject drop-down list lets you manage subject database, adding new subjects or editing them. 

Fig. 4.3: Subject list. 
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Tool let you edit settings, language and theme of the interface. 

Fig. 4.4: Tool list components. 
 
 

View let you change positioning of toolbar or see the abstract of the opened file. 

Fig. 4.5: View options. 
 
 

Acquisition let you to control the acquisition process. 

Fig. 4.6: Acquisition menu, signals acquisition options. 
 
 
 
Help gives information on how/ here to find information (tutorial, short cut from keyboard) and send a 
message to the manufacturer 

Fig. 4.7: Help list, where find information about software. 
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Extra provides additional data viewing and export options. 
 

Fig. 4.8: Extra options, additional tools. 
 

 
 

5 SETTINGS & PRIVACY 
 
Settings form let you control some accessories parameters, like default saving folder, Setup style, Font, 

Privacy or Device Settings. 

Privacy let you choose which info you want to share with OT Bioelettronica (Fig. 5.1). Info requested 

are only for statistical reason, in order to improve OT BioLab+ performance. No acquired data will ever 

be shared with OT Bioelettronica. 

Device Settings allows you to select the desired inputs for each device (Fig. 5.3). 

Fig. 5.1: Setting window. 
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Fig. 5.2: Privacy Settings window. 
 

 
 

Fig. 5.3: Device Settings window. 
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6 ACQUISITION SETUP 
 

In order to setup your acquisition, choose your device and sampling frequency. Then fill the form with 

Adapters, Electrodes and Parameters you want for your acquisition. When you finish the setup, click on 

“Setup complete” to save it, see Fig. 6.1. 

Fig. 6.1. OT BioLab+ Acquisition Setup Editor TreeView. 

 

You can choose between TreeView Setup and Grid Setup. In order to choose it, look in the Settings 
form. 
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7 SIGNAL ACQUISITION 
 

 
In order to start an acquisition, click on Acquisition > Start Visualization or click on the Play button on the 

toolbar from the main interface (see Fig. 7.1). 

Fig. 7.1: Strat visualization icon 
 
 

If there are problems with the device or software appears an error message, as you can see in figure 

7.2. 

 

Fig. 7.2: Error message window. 

 

 
After pressing start visualization, 3 forms are visible: 

1. Main: main interface, where acquired signals are always visible. 

2. Channel List Real Time: a resume list that shows which signals are available and where. 
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3. Performances: a chart that keeps the user informed of performances required by the 

acquisition. If it grows too high, there is the risk of acquisition fail and data loss. 

 
Clicking on Acquisition > Start Recording, a file start being filled with data acquired. Clicking Acquisition 

> Stop Visualization, acquisition will be stopped without saving. Clicking Acquisition > Stop Recording 

acquisition will be stopped and saving process will start (Fig. 7.3). 

When saving, choose the subject that performed the experiment selecting it from the subject database 

and then save it where you prefer. 

At the end of saving process, acquisition will restart automatically, so, if you want to stop the display 

and exit the process you must click on Stop Visualization. 

Moreover it is possible to define the end of the acquisition process going to set the recording time "End 

process in", at the end of the time the recording is stopped and you are asked to save the data (see in 

Fig. 7.4). 

Fig. 7.3: Visualization and recording window. 
 
 

Fig. 7.4: Visualization/recording buttons. 
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8 REAL TIME PROCESSING 
 

One of the most important improvements of OT BioLab+ is the introduction of Real Time Processing. 

They can be called from the Real Time Channel List right clicking on the signal of interest and choosing 

the processing you prefer. 

8.1 MOVE TRACK TO 

This processing let you clone the track on another form in order to have a copy of the signal and see it 

better (see Fig. 8.1). 

 

8.2 TRIGGER THIS TRACK 

The trigger real time processing is a visualization tool that let the user see tracks only when they are 

triggered by another acquired signal. 

For instance, it is possible to show tracks only when a signal on the input is high, or when it raises, etc. 

This processing can be applied on every track, but can be triggered only by an AUX channel. 

Fig. 8.1: Move track to allow to move the track to another form, for better visualization. 
 

8.3 EEG DISPLAY OPTIONS 

This processing applies a real time high pass filtering at 0.1 Hz in order to remove the DC from the 

signal. This processing let also apply a real time plug-in changes the acquisition mode from monopolar, 

detection of signals with respect to an electrode positioned in a region of inactivity (e.g. earlobe), to differential, 

by selecting the electrode of the cap with respect to which the differential signal is to be calculated. 

8.4 ACTIVATION MAP 

This processing is available only for matrices 32 or 64 channels and let you see an activation map in 

order to identify the zone that is more active. A real time barycentre is shown on it. Colour of the map 

depends on the amplitude of the ARV of signal acquired (Fig. 8.2). 

Refresh epochs are 1Hz, 2Hz or 4Hz. 
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Fig. 8.2: Activation Map during signals acquisition. 
 
 

8.5 ARV BAR 

This processing shows the bar chart whose value is the amplitude of ARV computed on an epoch of 

62.5 ms (Fig. 8.3). The refresh rate is 16 Hz. 

Fig. 8.3: ARV chart and ARV bar during acquisition. 
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8.6 ARV CHART 

This processing shows a chart with the value of amplitude of ARV computed of an epoch of 62.5 ms (Fig 

8.4). The refresh rate is 16 Hz. 

Fig. 8.4: ARV chart during acquisition. 
 
 

 

8.7 DIFFERENTIAL 

This processing is available only for matrices 32 or 64 channels. This processing will ask confirm about 

which is the matrix used for recording and will ask the direction of differential. Then it will compute the 

number of groups to plot (depending on matrix and direction) and will fill it with the difference 

between the correct signals. 

When the direction (horizontal or vertical) is selected, the image is rotated and the arrow 

corresponding to the direction also rotates, and the names of the tracks generated by the plug-in 

change correctly from row to column with respect to the presentation of the image. In other words: 

• when the difference is made horizontally, the groups of traces generated are named as row 

from 1 to number of rows; 

• when the difference is made vertically, the groups of traces generated are called col from 1 to 

number of columns. 

Line 1 is the most top, column 1 is the most left. As shown in Fig. 8.5. Therefore the first channel of 

each group is the difference of the two electrodes in the direction of the arrow. 
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Fig. 8.5: Differential plug-in parameter. 
 
 
 
 
 
 

Fig. 8.6: Differential tracks results 
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8.8 FFT 

This processing can be applied only to a single signal and shows the Fast Fourier Transform (FFT) over 

the last second acquired (Fig. 8.7). 

Fig. 8.7: Fast Fourier Transform result. 
 
 
 

8.9 TRAPEZOIDAL FEEDBACK 

The Trapezoidal feedback allows to perform experiments in which we want to record muscle activity 

during a force task. 

After connecting the force device to the acquisition system and starting the acquisition, it is possible to 

select the Trapezoidal feedback, initial screen shown in the figure 8.8. 

Fig. 8.8: Trapezoidal feedback processing start window. 
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You can see the yellow dot representing the force indicator, while the blue path indicates the force 

course that the subject should follow during the task. it is possible to set the display visualization and 

choose between the use of the Absolute or Relative MVC. In Absolute mode the value of MVC is 

calculated with respect to the absolute scale, and it is possible to set the value of the scale to be 

displayed and the scale factor, in case you want to display the values of force, for example, in Kg instead 

of V. In Relative mode you can set an arbitrary MVC value or calculate it directly and then display in 

relative scale values, compared to the indicated MVC. (see Fig 8.9) 

Fig. 8.9: Setting options. 

 

Clicking on Start Protocol the yellow dot start moving on the screen leaving a blue drift, so that it is 

possible to see the requested path and the performed path. Refresh rate is 16 Hz. Through the 

Settings button you can access to path settings, in witcht it is possible to define the path to be followed 
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during the task (see figure 8.10).  

 

Fig. 8.10: Path Setting. 
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9 SIGNAL REVIEW 
 

OT BioLab+ allows to open and review different file types. There are three methods to load a file: 

using the Open function under the File menu, from the Menu toolbar, or using the Import function 

under the same menu and toolbar. The Open method simply open a new file and, in case other signals 

are currently opened, there are two ways, if the file is the same type (extension .otb) are kept open in two 

separate main, otherwise if the new file is different type (e.g. .bio) this is imported in the same main. Import 

method keep the currently opened signals and adds the new ones under them. 

The Import function can be particularly useful, for example, when signals recorded using more devices. 

9.1 FILE EXTENSION 

OT BioLab+ can manage different kind of files: 

• otb+: files created by OT BioLab+ containing acquired signals, setup details, subject information, 

processing data and workspace. This format will be used only if the raw data dimension is smaller 

than 400 Mbytes. In case the RAM of the PC is not sufficient to save this amount of data, the files 

can be recovered because saved in.xml format (see below) in the same path previously chosen, in 

a folder named “temp”; otherwise the files are saved in the .otb format and the “temp” folder will 

be deleted automatically. 

• otb: files created by OT BioLab containing acquired signals, setup details, subject information, 

processing data and workspace. Also for these files the same storage rules apply. 

• brx: files generated by bruxoff and containing two EMG signals and one ECG signal. 

• emg: files generated by μEMG  or  μEMG-S and containing a single EMG channel. 

• frc: files generated by P-ForceMet and containing a single force channel. 

• bio: files generated by foremg and containing 4 EMG signals. 

• txt: any text file containing data can be opened. To open it, OT BioLab+ require some details 

regarding the format. For this reason a Text File Information window appears asking the user to 

choose the decimal separator, the columns delimiter, the time column or at least the time 

increment between subsequent lines. When all the information are inserted it is possible to open 

the data. 

• xml:  

- If the file data is larger than 400 Mbytes, due to large acquisition times, a message at the 

end of the acquisition will inform the user that the file has been saved in a different folder 

(see Fig. 9.1). In this case it is possible to visualize the data using the OT BioLab+ Open 

menu window also selecting the .xml file format and choosing this file named as the folder 

name. 

- abstract.xml files are generated by an old generation software called Acquisition Software. It 
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does not contain signals but all the information related to the signals acquisition and provide 

links to one or more .sig files containing the data. When opening one abstract file .xml it is 

possible to open one or more related signal files. Several files .xml are generated by OT 

BioLab+, but the open function is reserved to abstract file created by Acquisition Software. 

• nrv: they are files generated by the Nerveana software. 

• pro: they are files generated by processing plug-in. 

 

 

 

 

  

 

Fig. 9.1: Storage message 

 

All files, once opened, can be processed, manipulated and saved as .otb+ file. 

 
 
9.2 REVIEWING A SIGNAL 

When opening a signal in Review Mode, OT BioLab+ displays a window similar to Fig.9.1. The tracks 

are displayed in the same way as for Visualization Mode and the same options to manage the tracks 

are available during the review (refer to Tracks options section). 

FIG. 9.2. Screenshot during signal review showing an example of signals. 
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Epochs 

In Review Mode, the signals are segmented in epochs. The epoch size can be defined by the user in the 

Set Epoch field, in the toolbar. The epoch segmentation is necessary for several processing plug-in. The 

signals can be selected in two ways: a left click on the Sensor name area selects the entire signals, a 

drag through the desired epoch while pressing the left mouse button selects a group of subsequent 

epochs. 

 
Edit Toolbar 

When more signals have been detected from a single sensor, they are grouped together by creating a 

multiple track. In Review Mode, it is possible to group and ungroup signals as desired. 

To ungroup signals select a multiple tracks and then press the minus green button on the Edit toolbar 

or select Edit ->Ungroup Selected Tracks from the main menu bar. All the signals related to the original 

sensor will be spitted in single tracks and moved under the last signal, in the bottom part of the OT 

BioLab+ Review window. The name of single tracks will be assigned automatically by keeping the 

enumeration of sensor channels. 

To group together two or more signals select the desired signals and then press the plus green button 

on the Edit toolbar or select Edit ->Group Selected Tracks from the main menu bar. The new multiple 

track generated will be moved under the last signal, in the bottom part of the OT BioLab+ Review 

window. 

A given track can be deleted if desired, by selecting the track and pressing the Delete red button on 

the Edit toolbar or selecting Edit ->Delete Selected Tracks from the main menu bar. Even if the track 

and related signals are no longer displayed, in any case, the originally acquired data is preserved in the 

otb+ file. 

 
View Toolbar 

The View toolbar and the View menu include several options for the review of signals. The available 

functions are: 

• Zoom In: increases the time view resolution by reducing the time window displayed. This function 

it is also accessible by using the mouse scroll wheel together with the CTRL button. 

• Zoom Out: decreases the time view resolution by enlarging the time window displayed. This 

function is also accessible by using the mouse scroll wheel together with the CTRL button. 

• Zoom to Selection: expand the time selection to fit the full screen. 

• Fit in Window: fits the entire signals to the full screen. 

• Abstract: displays the information contained in the abstract file associated to the file opened. The 

abstract will be open with a template generated in Excel. 

• Search for Abstract: search tool that allows to find a particular file by searching for abstracts 

defined fields. 
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Moreover keyboard shortcuts are available to better visualize the parts of interest, as shown in the table 

9.1. 

 

Combination Position Effect 

CTRL + Left click channel list Set Track Size 

Double Click track Set Track Size 

DEL/CANC track Delete Track 

CTRL + mouse wheel everywhere Zoom In/Out 

CTRL + Left click tracks Multiselection 

F11 everywhere Hide/Show toolbar 

F2 everywhere Open Setup 

F5 everywhere Start Visualization 

F6 everywhere Stop Visualization 

F9 everywhere Start Recording 

F10 everywhere Stop Recording 

CTRL + O everywhere Open 

CTRL + G on multi selected track Group them 

CTRL + U on multi selected track Ungroup them 

CTRL + A everywhere Select all tracks 

CTRL + Up everywhere Zoom In 

CTRL + Down everywhere Zoom Down 

CTRL + 0 everywhere Zoom to selection 

A everywhere Move Tracks to the Left 

D everywhere Move Tracks to the Right 

W on selected epochs Zoom 1:1 on selected epochs 

S everywhere Fit in window 

Q everywhere Go to begin track 

E everywhere Go to end track 

CTRL + C everywhere Copy Settings 

CTRL + V everywhere Paste Settings 

Arroy key LEFT everywhere Move Selection to Left Epoch 

 Arrow key RIGHT everywhere Move Selection to Right Epoch 

SHIFT + arrow key LEFT/RIGHT everywhere Increase Epochs Selection  

Tab. 9.1: Keyboard shortcuts. 
 

Subject Toolbar 

Every signal acquired has to be stored together with subject details. For each subject it is possible to 

create a record containing all the related data. The records are collected into a database. OT BioLab+ 

give the user the possibility to manage different databases. This feature can be useful for privacy 

aspects when more user use the same PC but they don’t want to share the subjects information. 

By default one database is created by OT BioLab+ during installation in a folder managed by the O.S. 

that the user can’t access directly. If the user don’t need more than one database no operation are 

required, automatically the default database is used and all the operation are performed on it. 

Alternatively, under Subjects ->Manage Database it is possible to create a new database or select an 

existing one. The database created by the user can be saved everywhere on the hard drive or external 
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memory devices with the desired filename. The extension, by default is .otdb. When a user database is 

selected, OT BioLab+ keep memory of the database even when the software is restarted. In case file 

.otd is removed, renamed or moved from the originally folder, by default the software switch to the 

default database. Subjects can be add to the database at the end of a recording, but it is also possible 

to insert new subjects at any time. In particular, it is possible to add new subjects to the database or 

find and edit the subjects record. Pressing the Add New Subject button in the Subject toolbar, the 

Subject Editor window appears (see Fig. 9.3). All the information related to a subject can be typed, 

few of them are compulsory, and then, pressing the OK button, the subject is added to the database. 

In case some information related to one subject has to be modified, it is possible to search the subject 

into the database, and then edit any desired field. The Find/Edit Subject button on the Subject toolbar 

open the search window. Any parameter of a subject can be used to find its record into the database. 

FIG. 9.3. Subject Editor window. It allows to add a new subject to the database or edit the information related to 

an existing subject. 

 
9.3 SIGNAL EXPORT 

It is possible to export the signals acquired using OT BioLab+ to use them with different software (e.g. 

Matlab, Excel, LabView etc.). Two are the methods to export the signals: “Selected signal(s)” or “Raw 

data set”. 

Using the option “Selected signal(s)” it is possible to export single or multiple tracks, the result of a 

processing or a subgroup of signals acquired. The export can be done using different file type: Binary, 

CSV or Matlab files. Refer to the following paragraph for further details. 

The “Raw data set” option allows to export the entire data set related to an acquisition. All the signals 

originally acquired and for the entire acquisition time are exported together regardless of any applied 

selection. The signals are exported in binary format. 
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Export binary data 

To use this option, during review, choose File->Export->Raw data set from the main menu bar. The 

signals exported are saved as a .sig file. All the signals originally acquired and for the entire acquisition 

time are exported together regardless of any applied selection. 

The .sig file exported is a binary file structured as a number of row equal to the number of channels 

acquired (i.e. number of rows occupied by sensors in the setup used during the acquisition) and a 

number of columns that depends on the signals duration. The sample values are signed short in the 

range -2048 ÷ 2047. 

The following formula can be used to obtain the signals amplitude x at the input of the amplifier, given 

each binary value N in the .sig file: 

X =  N 
𝑣𝐴𝐷 ⋅ 1000

2
𝐴𝐷𝑅𝐸𝑆

⋅ 𝐺ain
[𝑚𝑣] 

 

where: 

•  ‘VAD’ is the A/D converter input range in volts 

• ‘ADRES’ is the A/D converter resolution 

• ‘Gain’ is the gain used during the acquisition for the corresponding channel 

• ‘1000’ allow to obtain the result in mV. 

For example, when using EMG-USB, EMG-USB2 and MEBA, the A/D converter input range (VAD) is 5 V, 

the resolution (ADRES) is 12 bits and the Gain for each sensor can be find in the abstract file. Note that 

the gain for AUX channels is 0.5 V/V since the inputs accept -5 ÷ 5V dynamics, but the A/D converter 

input range is 0 ÷ 5V. 

 
Export CSV data 

Single channels, subgroups of acquired channels or processing results can be exported in CSV (comma 

separated value) format. To export a .csv file select the desired tracks, choose File->Export->Selected 

signal(s)->As CSV file from the main menu toolbar. An error will occur if track with different sampling 

frequency are selected to be exported together. 
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After the filename and the position has been selected the Export Settings window is displayed (see Fig. 

9.4) where it is possible to select the type of header and decimal separator. 

Fig. 9.4: Export Settings window. It allows to set the exporting options. 

 

The data is exported with signals amplitude estimated by OT BioLab+ representing the input signals at 

the amplifier inputs, taking into account the gain used during the acquisition. By default the time 

columns is added and the measurement units are indicated in the file header. 

Note that it is not possible to export simultaneously different tracks if they has been acquired with 

different sample frequencies. 

 
Export Matlab Files 

Single channels, subgroups of acquired channels or processing results can be exported in as a Matlab file. 

To export a .mat file select the desired tracks, choose File->Export->Selected signal(s)->As MAT file 

from the main menu toolbar. An error will occur if track with different sampling frequency are selected 

to be exported together. 

The .mat file exported can be open using Matlab. After the file has been open different variables will be 

added to the workspace: 

• Data: an N-by-M matrix containing the exported data, N is the number of samples exported, 

M is the number of channels exported; 

• Description: an M row vector containing the description of each channel exported; 

• OTBFile: is the path and filename of the .otb file where the data has been exported; 

• SamplingFrequency: is the value in Hz; 

• Time: is an N row vector containing the time instant for each sample of the exported data. 

After the file loading the Matlab command plot(Time, Data(:,1)) will produce a graph of the first 
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channel exported versus the time. 

 
10 SIGNAL PROCESSING 

OT BioLab+ allows to process any kind of signals managed by the software itself (refer to the File 

Extension section). The processing tools are available in Review Mode. Processing functions are 

accessible under the Processing menu or with right click on channel list. 

There are processing plugins that can be only applied to single tracks and other processing can be 

applied both to a single tracks or to a multiple tracks (refer to Track Options section). 

All the processing tools do not change the recorded signals but generate new tracks under the last 

existing track. 

10.1  ABSOLUTE VALUE 

The plugin, when applied, simply rectify the signals. 
 
10.2  AMPLITUDE 

This processing tools use some standard amplitude estimators to generate two new single tracks 

containing the results. The estimators are the Average Rectified Value (ARV), the Root Mean Square 

(RMS), Signal To Noise Ratio and Epoch Average. The resulting tracks generated are added under the 

last existing track. In all cases a value for every epoch is calculated and displayed as a point in the 

middle of each epoch. When the zoom is set to display more epochs, the points are connected each 

other by displaying a line between each adjacent points. 

 

The estimation of ARV (AARV) is obtained for the epoch i using the following formula: 

 

AARv(i) =
1000

N
∑|xk|[μv]

N

k=1

       

 
where: 
 

 

- ‘N’ is the number of samples per epoch 

- ‘Xk’ is the amplitude of the signal at the input of the amplifier in mV. 

- ‘1000’ allows to obtain the result in μV. 

 

The estimation of RMS (ARMS) is obtained for the epoch i using the following formula: 
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ARMS(i)  =  1000√
1

N
∑ 𝑥𝑘

2

𝑁

𝑘=1

  [µV] 

where: 

• ‘N’ is the number of samples per epoch. 

• ‘Xk’ is the amplitude of the signal at the input of the amplifier in mV. 

• ‘1000’ allow to obtain the result in μV. 

 

The estimation of Signal To Noise Ratio is computed as the Ratio between the highest RMS value of the 

track and the lowest one. 

 

The estimation of Epoch Average is the mean value of each epoch. 
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10.3  Band Pass EEG 

This processing will extract from one signal the characteristic 5 bands of the EEG signals (see 

Fig 10.1). 

 

Fig 10.1: Band Pass EEG parameters. 
 

 

10.4  CALIBRATION 

This processing plugin can be used to calibrate a signal acquired for example using a load cell to obtain 

the trace directly expressed in the correct measurement unit and with the correct scale. Moreover it is 

possible to remove an offset to obtain the correct zero level. 

 
 

10.5  CONVOLUTION 

This processing performs convolution between two signals in order to recognize the highest cross 

correlation between them. Once it recognize it, it will shift in time the second signal in order to align 

them. 

10.6  GROUP AND UNGROUP TRACKS 

This plug-in is necessary to obtain, starting from the grouped signals, the single signals associated to 

each channel and vice versa to group together the individual tracks related to the channels. 

Ungroup: 

• Select the grouped signals  
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• Click on minus icon 

Group: 

• Select more tracks you want 

• Click on plus icon 

In the last track below you can see the result of the ungrouping/grouping plug-in. 

10.7  CONDUCTION VELOCITY ESTIMATION 

This tool has been designed for the estimation of conduction velocity (CV) from single differential 

signals detected by an electrode array. It is possible to use three  different plug-ins to estimate the CV. 

The first plug-in that appears in the dropdown menu under “CV Estimation” is named “Conduction 

velocity Phase Delay (3 signals)” and it requires three single differential signals to estimate a CV value. 

The three signals must be three single tracks selected by the user. The tracks can be grouped or 

ungrouped (see section 10.6). In case the user needs to use the “free selection” on tracks it is 

recommended to group tracks to optimize the selection. 

The algorithm calculates two double differential signals from the three single differential signals and 

then estimates the delay between the two signals obtained in a least square sense in the frequency 

domain. For further details on the delay estimation refer to: “McGill K.C., Dorfman L.J. High-resolution 

alignment of sampled waveforms. IEEE Trans Biomed Eng, BME-31: 462–468, 1984”. 

 
Once the delay is estimated, CV is obtained dividing the distance between electrodes by the delay 

obtained. The indication of the Inter Electrodic Distance (IED) is first of all searched in the sensor 

name field of the signals, in case it is not found it is asked to the user. 

The track containing the results is added under the last existing track. A value for every epoch is 

calculated and displayed as a point in the middle of each epochs. When the zoom is set to display more 

epochs, the points are connected each other by displaying a line between each adjacent points. 

The second plug-in that it is implemented is based on a different algorithm and is named “Multichannel 

Conduction Velocity”. With this plug-in it is possible to select and use different channels (three or more) 

to estimate the CV. Also in this case the tracks can be groped or ungrouped. In case the user needs to 

use the “free selection” on tracks it is recommended to group tracks to optimize the selection (see 

Fig.10.2). 
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Fig. 10.2: Multichannel CV plugin used on grouped signals. 
 

 

This multichannel algorithm estimates the CV in the frequency domain. The algorithm is described in 

the paper: “ “Assessment of average muscle fiber conduction velocity from surface EMG signals during 

fatiguing dynamic contractions.” D.Farina et al, IEEE Trans Biomed Eng. 2004 Aug;51(8):1383-93”, and it 

provides an estimation of the CV from a set of EMG signals in a time interval in which the mean square 

error (MSE) between aligned signals is minimized. The minimization of the MSE function is performed 

in the frequency domain, without limitation in the time resolution and with an iterative computationally 

efficient procedure. The algorithm that is implemented in OT Biolab+ uses a rectangular window with 

an amplitude of unity. This choice was adopted in order to minimize the computational time of the 

algorithm. The CV is calculated for epochs as for the previous algorithm. The track containing the 

results is added under the last existing track. The value for every epoch is displayed as a point in the 

middle of each epoch.  

The third plug-in is named “Windowed conduction velocity” and it allows to calculate the CV at the 

center of a free selection. The signal is windowed in time domain by a Gaussian function. The 

algorithm used is the same of the Multichannel CV, so three or more signals  can  be selected. In this  

case it is  necessary to group the  tracks  in which the user calculates the CV. Using the free selection 

the plug-in calculates the CV at the center of the selected time interval as reported in Fig. 10.3. When 

this plug- in is selected a window will appear to select the desired sigma in milliseconds of the 

Gaussian window. The calculated value is reported in a new track at the center of the selected interval 

(see Fig. 10.3). 
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Fig. 10.3: Example of a windowed CV calculated with a Gaussian function (sigma of 30 ms). 

10.8  DATA APPROXIMATION 

OT BioLab+ can provide different type of data approximation. In particular, four different tools are 

grouped under the Data Approximation menu voice: average, linear, standard deviation and parabolic. 

The four approximations can be applied at any kind of single track but they are intended to be applied 

on processing results based on epochs: amplitude, frequency or conduction velocity estimation results. 

When running a data approximation on a track, the software calculates the polynomial curve with the 

desired grade best fitting the data set, minimizing the square error. The polynomial curve obtained is 

superimposed to the track containing the data set and drown in red. The identified coefficients are 

indicated in the sensor name. 

10.9  DECOMPOSITION > DECOMPONI 

The plugin, when applied, decompose the grouped signals. When you select the grouped signals and 

click on Processing > Decomposition > Decomponi then visualize a Settings form (Fig. 10.4) where you 

can set parameters of decomposition algorithm, as shown in figure below. Then appears a window 

where you can approve or refuse the motor units (Fig. 10.5), when you click Save only approved MU, in 

the main window get a grouped signals with a spike when the motor unit fires (see figure 10.6). 

Fig. 10.4: Settings Decomponi algoritm. 
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Fig. 10.5: Selection of Extracted Motor Units. 

 

Fig. 10.6: Grouped Firing rate signals from approved MU 

10.10 DECOMPOSITION > EXTRACT MOTOR UNITS 

This plugin shows the template of the decomposed motor units. In order to use this plugin, proceed as 

follows: 

1 Select grouped signals and grouped firing rate decomposition (see figure 10.7). 

2 Run Processing > Decomposition > Extract Motor Units 

3 Choose the right matrix 

4 Choose the orientation 
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5 Choose the display time  

Fig 10.7: Double selection of grouped signals. 

 

In figure 10.8 it’s displayed the Motor Units extract by the algoritm.. 
 
Motor units can be exported as Matlab structure or as a csv file where there are firing samples. 
 

 
Fig. 10.8: Motor Unit extraction result. 

 

10.11  DECOMPOSITION > MEAN  FIRING  RATE 

This plugin can be applied to decomposed signals. This plugin draws a curve showing the firing rate of 

motor units during acquisition. 

In order to have a best sight of the mean firing rate, please do as follows: 
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1 Select the grouped firing rate signals 

2 Run Decomposition > Mean Firing Rate 

3 Right click on the mean firing rate signals 

4 Set Vertical Range 

5 Use superimpose channels 
 
 
10.12  DERIVATIVE 

Performs derivative of a signal. 

 
10.13  ENVELOPE 

Extract the envelope from a single track and normalize it with respect to the envelope maximum peak. 

The tool has been designed for EMG signals, the resulting signal is obtained by rectifying the desired 

signal and applying a II order Butterworth low pass filter with 5 Hz corner frequency to the rectified 

signal. 

10.14  FFT 

The FFT can be estimated from single tracks on the desired number of epochs. After selecting the 

track a window will appear (Fig. 10.9) for selecting the number of samples that will be used to obtain 

an averaged FFT to reduce the noise in the estimated power spectrum. A minimum of 256 samples 

for the averaged FFT is required. The maximum number of samples is equal to the length of the data. 

From this menu the user can select the window functions to apply to the time domain data for 

estimating the FFT (rectangular, hanning, hamming, blackman). Samples used to obtain the averaged 

FFT can be overlapped (50 % of overlap - Welch’s method) or no overlapped (Barlett’s method) 

selecting the options that appears on the bottom-right of the window menu. After selecting these 

options a new window will display the result of the algorithm (Fig. 10.10). Details about the FFT 

algorithm can be found at   http://sourceforge.net/projects/kissfft. After the FFT has been estimated, 

keeping the left mouse button pressed a rectangular window can be drawn to indicate the area that 

the user want to zoom in. When a right click on the FFT zoom out will be performed. 

 

Fig. 10.9: Window menu for selecting number of samples. 

http://sourceforge.net/projects/kissfft
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Fig. 10.10: An example of an FFT spectrum obtained averaging 1024 samples is shown. 

 

10.15  FILTERING 

This processing tool can be applied both to single tracks and multiple tracks. When running it, a 

request of filter type and corner frequencies is displayed. It is possible to choose between different type 

of filters: 

• Low pass 

• Band pass 

• High pass 

• Stop band 
 

Moreover, the corner frequencies are differently asked depending on the filter type selected. 

The signals generated by the filtering process are added as single or multiple track in the review 

window leaving unaltered the starting signals. All filter types are II order Butterworth filters. 

 

10.16  FREQUENCY 

This processing tool uses two standard frequency estimators to generate two new single tracks 

containing the results. The estimators are the Mean Frequency (MNF) and Median Frequency (MDF). 

The two tracks generated are added under the last existing track. In both cases a value for every epoch 

is calculated and displayed as a point in the middle of each epochs. When the zoom is set to display 

more epochs, the points are connected each other by displaying a line between each adjacent points. 

The estimation of MNF (fMNF) is obtained for the epoch i using the following formula: 
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fMNF(i) =
∑ Ik

n
k=0 ⋅ fk

∑ Ik
n
k=0

  [Hz] 

where: 

 
• ‘n’ is the number of frequency bins in the spectrum 

• ‘fk’ is the frequency of spectrum at bin k of n 

• ‘Ik’ is the Intensity of spectrum at bin k of n 

 

The estimation of MDF (fMDF) is obtained by comparing the total signal spectrum intensity divided by 

two with the cumulative intensity (i.e. all the intensity values for frequencies lower and including the 

focal intensity). The lowest frequency retrieving the cumulative intensity bigger than the half total 

intensity is fMDF. 

 

10.17  ACTIVATION MAP 

Maps plugin allows show in a 2D plot the matrix signals of 64 electrodes or 32 electrodes with different 

colour scales. 

The maps plugin has been designed to process data acquired as MONOPOLAR signals. After selecting 

the matrix type a new window will appear with the visualization of the colour map. On the left side of 

this window, different options are available in order to change the visualization of the map depending 

on the type of analysis that is chosen (see Fig. 10.11). 

Fig. 10.11: Visualization of the colour map and of the menu with different options that can be modified 
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From the menu map different mode of visualization can be selected: Monopolar, Horizontal differential 

and Vertical differential. With the Monopolar mode, the plot is generated from the original signals 

without additional processing. The Horizontal differential mode allows to perform the difference 

between contiguous electrodes of the monopolar signals from left to right of the matrix rows. The 

Vertical differential allows to perform the difference between contiguous electrodes of the monopolar 

signals from top to bottom columns of the matrix. 

The maps can be displayed with two different options: ARV or RAW data. 

Choosing the ARV option, the software estimate, for each signal, the average squared values over the 

epoch selected in the OT BioLab+ main window (e.g. 0.5 s in Fig. 10.10). A cursor bar in the top of the 

visualization window can be moved to select the colour map at a certain time. A “Play” button in the 

left side of this bar can be used to start an automatic display of the maps during the acquisition time 

or to stop it. 

In the RAW option, the instant values over the acquisition time are used to generate each map. With 

this option it is possible to display the acquired data by showing the propagation of the action potential 

along the muscle fibers. Three different colour bars are available: “Jet”, from blue to red, “Heat”, from 

black-red- white and “Bone”, a modified grey scale with a blue colour. 

Four different rotation angles can be chosen: 0, 90, 180 and 270 degrees with respect to the 

orientation that is reported in the left-bottom side with a picture of the selected matrix. The minimum and 

the maximum value of the colour range is reported in μV and can be changed in the menu. These 

values are also updated and reported in the right side of the colour bar. 

The minimum and the maximum value can be changed only when the check box of the autorange is un-

checked. 

 

10.18  MAX - MIN AND MEAN 

This processing computes max, min and mean value of the selected signal. 
 
10.19  PSD 

The power spectral density (PSD) can be estimated from single or multiple tracks on the desired 

number of epochs. As in the FFT plugin, after selecting the track a window will appear for selecting the 

number of samples that will be used to obtain an averaged FFT to reduce the noise (see FFT plugin for 

details), the window functions and the method (Welch or Barlett’ method). After selecting options of 

this menu two plots will show the PSD of the signal in two different units: dB/Hz and mV2/Hz. As an 

example in Fig. 10.12 a PSD signal is shown in logarithmic scale. 
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Fig. 10.12: Example of a PSD spectrum obtained averaging 1024 samples of an EMG channel, the plot is reported 

in logarithmic scale. 

 

10.20  QUALITY CONTROLLER BUFFER/RAMP 

This two plugins can be applied only on signals acquired with devices that provide ramp or buffer. They 

show the ramp or the buffer recorded during acquisition. 

 
10.21  SUM 

This processing tool can be applied to a multiple track or to, at least, a pair of single tracks. Simply it 

calculates, sample by sample, the sum between signals. 

When applied to a multiple track it calculates the sum between all channels associated to the sensor 

selected and retrieve a new single track containing the sum. 

Typical application is the use with signals from an electrode array; the processing calculates the signals 

virtually obtained with multiple inter-electrodic distance. 

10.22  TIME SHIFT 

This processing will shift the signal in time. When you run this processing, it will ask you how many 

samples you want to shift the signal. If the number is negative, it will move the beginning of the signal 

forward in time, delaying it. If it will be positive, it will remove the first part of the signal. 

 
11 MATLAB CODES 

In the installer there are some examples file for Matlab coding. They are available under the path 
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C:\Program Files\OT BioLab+\MatlabCodes. 

This folder is protected by Windows, then you will have to copy files under another path in order to edit 

them. 

 

12 IMPEDANCE CONTROL 

Impedance control is a controller for Sessantaquattro when used for EEG recording. It shows the 

impedance of the skin in order to let the user understand if the contact skin - electrode is good 

enough. 

 
13 OTCOMM 

All the communication is managed by the library OTComm.dll. It is possible to use it also without using 

OT BioLab+. 

Some examples are available under Matlab codes. 

Documentation for OTComm.dll is available in C:\ProgramFiles\OT BioLab+\Documentation. In order to 

use OTComm, you just need to import OTComm.dll in your project. It is available in the folder 

C:\Program Files\OT BioLab+. 

 

14 PC REQUIREMENTS 

Operative system: Windows 10 Processor: 

Intel i3 2nd generation. Port: USB2.0 and 

Ethernet 

Hard Disk: 500 MBytes for software installation Minimum 

RAM: 2 GBytes 

The minimal PC requirements listed allows the proper acquisition of all 256 channels of EMG-USB2 

equipment (with max sampling frequency 10.240Hz) and a visualization of 16 channels simultaneously. 

The increase of the number of visualized channels can produce a visualization latency or an 

intermittent visualization. 

 

 
15 PROBLEM SOLVING 

A problem for the visualization of sensors in the Setup Editor can occur in case the old version of the 

software has not been uninstalled before the installation of the new software. 

In order to install correctly the new version 1.2.*.*, the old version of the software should be 

uninstalled before, running the unins000.exe file located in C:\Program Files\OTBioLab+. If the problem 

remains after the installation of the new software, the folder C:\ProgramData\OT Bioelettronica must be 

cancelled manually. 
 
Usually C:\ProgramData\ folder is an hidden folder of the Windows operative system and can be shown 

using the procedure of Windows “Show hidden Folders”. 
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16 OT BIOLAB LIGHT 

OT BioLab Light has been developed in order to let the user acquire using directly from a socket 

without visualizing data in OT BioLab+. It is automatically installed together with OTBioLab+ and can 

be searched in the application bar or in the OTBioLab+ folder. 

Using OT Biolab Light, you can just configure roughly the acquisition and start it. Then you will be able to 

connect using another software that will read the data coming from a socket. Data can be read also from 

another computer available in the same network. OT BioLab Light can be used with this devices: 

• EMG-USB2+ 

• QUATTROCENTO 

OT BioLab Light creates a socket on the localhost on the port 31000. Interface is shown in Figure 15.1. 

If you want to use Quattrocento, you have to set parameters. Clicking on Edit the Figure 15.2 will 
appear. 

You can set the refresh frequency on the main interface. Refresh frequency is the frequency of data 

available on the socket for the reading. 

In order to see data, you just need to open the socket and send the start command. When you open 

the socket, you will receive 8 bytes. They are “OTBioLab” written in ASCII code. 

Fig. 16.1: OT BioLab Light interface. 
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Fig. 16.2: OT BioLab Light interface. 

 
Detailed command and answers are: 

• startTX: this command starts the communication with the socket. 

• stopTX: this command stops the communication with the socket. Data are provided as 

short in little endian. 

An example of communication is shown in the Matlab Codes folder. 
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17 TROUBLESHOOTING 

 
17.1 SESSANTAQUATTRO IS BLINKING 4 TIMES BUT DATA ARE NOT VISUALIZED. 

Solution 1: Windows Firewall. 

Open Windows Defender Firewall with Advanced Security. Select Inbound Rules 

 

Fig. 17.1: Windows Defender Firewall with Advanced Security. 
 

 

Allow all OT BioLab+ Rules 
 

Fig. 17.2: Software rules. 
 

 

In order to allow them, right click on it, choose Properties and Allow the connection. 
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Fig. 17.3: Choose OT BioLab+ property. 
 

 

If there are no OT BioLab+ rules, then you have to create a new rule. 

 

 
Fig. 17.4: New rules section. 
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• Choose Program 
 

Fig. 17.5: Choose Program in Rule Type. 
 

• Browse to C:\Program Files\OT BioLab+\OTBiolab+.exe 
 
 

 

Fig. 17.6: Choose Program path. 
 

• Choose Allow connection 
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• Check all the checkbox (Domain, Private, Public) 

• Give a name to the rule (OT BioLab+) 

• Click finish. 

 

Solution 2: Antivirus. 

If solution 1 does not work, very likely the problem is the Antivirus. In this case try to disable it. 

 

17.2 SESSANTAQUATTRO: DATA VISUALIZED ARE ALL                                  ZEROES. 

In this case, very likely, the ground reference is not well connected. Data are then in saturation and 

resulting data are all zeroes. Please check the setup in order to control that connections are fine. 

If you choose acquisition as EEG, then, you will be able to see the signals and check if it is a saturation 

problem. 

 
17.3 SESSANTAQUATTRO:          AUTOMATIC            RECOGNITION      FAILED.      CONTINUE? 
 
When this message pops up, it means that the automatic recognition of Sessantaquattro failed. It does 

not mean that you will not be able to connect, but just that you will have to take care of  IP recognition. 

If connected directly to the device’s net, then you can continue without any problem. If, instead, you 

are connected to an external hotspot, then you will have to manually connect to the Sessantaquattro 

in order to let the Sessantaquattro understand which will be the path for OT BioLab+.  In order to 

manually connect to the Sessantaquattro, just connect to the Sessantaquattro IP using a browser. 

From that moment on, Sessantaquattro will look for the Socket generated by your PC. If you do not 

know the IP of Sessantaquattro, you can check on your router administration page or use external 

software like Bonjour Browser. 

 
17.4 DECOMPOSITION FAILED. DID YOU INSTALL THE DRIVERS? 

For the most of Windows 10 it is not necessary to install Microsoft redistributables, but for some pc it 

could be necessary anyway. 

In this case open the folder 

C:\Program Files\OTBioLab+\Drivers\Decomponi and run: 

• vcredist_2013_x64.exe 

• vc_redist.x64.exe 

Then reboot the PC. Now Decomponi should work properly. 

 

17.5   DECOMPOSITION 
 

Decomposition fails and show a Message that says the file has not been found. 
 
There are 2 possible reasons: 
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1. PC is not 64 bits. In this case algorithm cannot be run. 
 

2. Microsoft Redistributables must be re-installed. Please re-install OT Biolab and check 

Decomposition drivers. Then run them when the popup will appear. 
 
If redistributables cannot be installed, please check windows updates and update the computer to the 

newest windows release. Then run again the installer.  

If the problem does not solve itself, please contact OT Bioelettronica customer service. 

 

17.6 DUEPRO 

 

If when running Acquisition with DuePro a Message that says Device not ready appears, then there are 

2 possible reasons: 
 

1. Dongle or Recharge station is not connected to the pc. In this case connect it. 
 

2. Dongle or Recharge station are not recognized by the pc. In this case reinstall OT Biolab and 

check DUEPRO drivers. Then follow instructions at point 3.2 of this Manual. 

 
 

 


